ページ更新時にエラーが出てしまうのは何故?

Warning: implode() [function.implode]: Invalid arguments passed in /home/sites/lolipop.jp/users/lolipop.jp-dp0*******/web/wordpress/wp-includes/post.php on line 1762

Warning: Cannot modify header information - headers already sent by (output started at /home/sites/lolipop.jp/users/lolipop.jp-dp0*******/web/wordpress/wp-includes/post.php:1762) in /home/sites/lolipop.jp/users/lolipop.jp-dp0*******/web/wordpress/wp-includes/pluggable.php on line 865

ページを更新」ボタンをクリックすると上記のエラーメッセージが表示されてしまう。再度更新した内容を表示してみると、更新はされている。
Warningだからイイのか?
このテーマはWordPressのバージョンに対応していないのが原因なんだろうか?